compatibilité versions

Gimp est le fabuleux logiciel open source de dessin 2D de qualité professionnelle.
Lomagnol
Messages : 2
Inscription : 24 nov. 2019, 14:02

compatibilité versions

Message par Lomagnol »

Bonjour,
je suis sous Mac Os X Yosemite, j'utilise la version 2.8.14 de Gimp, en 32 bits. Je dois faire une mise à niveau de l'Os pour passer sous Catalina, mais cet Os n'accepte que les logiciels en 64 bits. Je chargerai donc par la suite une version plus récente de Gimp, en 64 bits.
La question est la suivante: me sera t-il possible avec une version 64 bits de charger des fichiers xcf réalisés avec une version 32 bits afin de les retravailler?
Merci pour vos réponses. Thierry.
undertaker
Messages : 1487
Inscription : 05 janv. 2005, 20:58
Localisation : LIEGE - BELGIQUE

Re: compatibilité versions

Message par undertaker »

Bonjour Lomagnom,

32 ou 64 bits ! Ça n'a rien à voir dans le travail avec Gimp pour autant que la version 64 bits soit installée.

Ces 32 ou 64 bits c'est, pour aire simple, la manière dont travail le microprocesseur. Il peut manipuler des mots (instructions pour le microprocesseur) d'une longueur de 32 ou 64 bits. En 32 bits, la quantité de mémoire que le processeur peut utiliser est bien moindre qu'en 64 bits.

32 bits : la plus courante chez les ordinateurs personnels, la valeur maximum représentable = 232 - 1 = 4 294 967 295; 64 bits : valeur maximum représentable = 264 - 1 = 18 446 744 073 709 551 615.

Tes fichiers, qu'ils aient été créés en 32 ou 64 bits, ça ne fera aucune différence pour GIMP.

A+
COGITO ERGO SUM.
Linux DEBIAN 10, Inkscape 0.92, Scribus 1.4.8 et aussi Gimp, Blender, ...
Lomagnol
Messages : 2
Inscription : 24 nov. 2019, 14:02

Re: compatibilité versions

Message par Lomagnol »

Bonjour Undertaker,
et merci pour ta réponse.
Pour un fichier jpg ou tiff ou autre de ce genre, je me doutais bien que peu importe qu'il ait été créé par un logiciel qui travaille en 32 ou 64 bits, mais pour un fichier xcf je n'en avais aucune idée.

Merci bien,
Thierry
undertaker
Messages : 1487
Inscription : 05 janv. 2005, 20:58
Localisation : LIEGE - BELGIQUE

Re: compatibilité versions

Message par undertaker »

C'est pareil. il n'y a pas de traitement différent que ton os soit en 32 ou en 64 bits.
Le 32 ou 64 bits est la manière dont Linux "découpe" les fichiers en petits paquets dans les mémoires (ram, hdd, ...) pour pouvoir travailler dessus. (Très très simplifiée l'explication :-) )
En 32 bits, ce sont des petits seaux de sables qui servent à déplacer les "morceaux" du fichier, en 64 bits, c'est un plus gros seau qui est utilisé ;-)

Bonne journée.
COGITO ERGO SUM.
Linux DEBIAN 10, Inkscape 0.92, Scribus 1.4.8 et aussi Gimp, Blender, ...
Répondre