Aiptek 12000U et pression dans le Gimp

Installation et utilisation des tablettes graphiques sous Linux.
Hoaxyde
Messages : 26
Inscription : 29 oct. 2005, 14:43

Aiptek 12000U et pression dans le Gimp

Message par Hoaxyde »

Salut,

J'ai fait l'acquisition d'une tablette graphique Aiptek.
Je la branche à l'ordi, directement reconnue, ça marche (bizarrement, à cause de mes 2 écrans, mais ça marche).
seulement dans le Gimp, je n'ai pas accès à "configurer les périphériques d'entrée étendus" (aucun périphérique).

Comment faire pour qu'il ouvre un peu les yeux et voie ma tablette ?
(et donc utilise la pression)

Merci
HoaXyde.
KiBi
Messages : 901
Inscription : 27 déc. 2004, 00:57
Localisation : Brest, Dijon
Contact :

Message par KiBi »

Salut.

Peut-être le module qui est automatiquement chargé n'est pas le bon et/ou tu n'as pas la configuration adéquate. Je te conseille de lire AIPTek topic officiel dans cette même catégorie.
Hoaxyde
Messages : 26
Inscription : 29 oct. 2005, 14:43

Message par Hoaxyde »

Merci pour ta réponse.

Je n'ai pas réussi à installer le pilote présenté dans ce sujet (en même temps, vu son âge, je m'en doutais)... j'utilise celui présent par défaut sur ma ubuntu (même si je sais que c'est pas bien Ubuntu).

:?
KiBi
Messages : 901
Inscription : 27 déc. 2004, 00:57
Localisation : Brest, Dijon
Contact :

Message par KiBi »

Je ne vois pas en quoi l'âge est un problème. Je l'ai installé sur un 2.6.15 il y a 2 semaines. (Et ça devrait s'installer sur un 2.6.16 sans souci.) Tu tournes sur quel noyau, quelle version d'ubuntu et quelle architecture ?
Hoaxyde
Messages : 26
Inscription : 29 oct. 2005, 14:43

Message par Hoaxyde »

L'erreur est :
3.
cp: accès de `/usr/src/linux/drivers/usb/input/': N'est pas un répertoire
sh: line 0: cd: /usr/src/linux: N'est pas un répertoire
sh: line 0: cd: /usr/src/linux/drivers/usb/input/: N'est pas un répertoire
[OK] aiptek.c copied in the kernel source tree
[ERROR] : unable to generate modules dependancies at ./aiptek-installer.pl line 481.


Je suis sur un 2.6.15, ubuntu dapper et i386 (sur un amd64).

Merci de ton aide, KiBi.
KiBi
Messages : 901
Inscription : 27 déc. 2004, 00:57
Localisation : Brest, Dijon
Contact :

Message par KiBi »

As-tu installé les « headers » (fichiers de développement) correspondant à ton noyau ? Un paquet se nommant linux-headers-2.6.15... (il y a la révision du paquet et l'architecture, sous Debian, par exemple : linux-headers-2.6.15-1-powerpc) ou quelquechose d'approchant. En fonction de comment il est ficelé (le paquet), tu auras peut-être besoin de faire un lien symbolique, quelquechose comme :
ln -s /usr/src/linux-headers-2.6.15-... /usr/src/linux

Ça devrait te permettre d'avancer un peu.
Hoaxyde
Messages : 26
Inscription : 29 oct. 2005, 14:43

Message par Hoaxyde »

Je ne peux pas, il y a déjà un fichier /usr/src/linux :?
KiBi
Messages : 901
Inscription : 27 déc. 2004, 00:57
Localisation : Brest, Dijon
Contact :

Message par KiBi »

ls -ld /usr/src/linux pour savoir vers quoi il pointe (en général c'est un lien symbolique vers des sources du noyau) ; pour forcer la création du lien symbolique, il suffit d'ajouter un '-f' comme option de 'ln', ce qui donne donc "ln -sf ...". Tu utilises bien un noyau fourni par Ubuntu, tu ne l'as pas compilé toi-même, au passage ?
Hoaxyde
Messages : 26
Inscription : 29 oct. 2005, 14:43

Message par Hoaxyde »

Ok, il s'est installé, avec quelques erreurs.

Code : Tout sélectionner

3.
/usr/src/linux/drivers/usb/input/aiptek.c:1083: attention : initialization from
incompatible pointer type
... (x fois la même erreur avec d'autres lignes) ...
/usr/src/linux/drivers/usb/input/aiptek.c:1953: attention : initialization from                                                                                                                     incompatible pointer type
/usr/src/linux/drivers/usb/input/aiptek.c:1970: attention : initialization from                                                                                                                     incompatible pointer type
make[1]: *** Pas de règle pour fabriquer la cible « /usr/src/linux/drivers/usb/i                                                                                                                    nput/ati_remote.c », nécessaire pour « /usr/src/linux/drivers/usb/input/ati_remo                                                                                                                    te.o ». Arrêt.
make: *** [_module_/usr/src/linux/drivers/usb/input] Erreur 2
cp: ne peut évaluer `/usr/src/linux/drivers/usb/input/aiptek.ko': Aucun fichier                                                                                                                     ou répertoire de ce type
[OK] aiptek.c copied in the kernel source tree
[OK] modules dependancies correctly generated
[OK] module successfully compiled
[OK] module copied
[OK] Your .config is in your kernel source tree
4.
cp: la cible `/usr/X11R6/lib/modules/input/' n'est pas un répertoire: Aucun fichier ou répertoire de ce type
[OK] a prebuilt X driver exist for your running kernel
[OK] prebuilt driver copied in you X path


Ça l'air d'avoir quand même marché.

Quel est le nom du pilote, pour que je teste et configure mon X ?
Celui défaut par présent s'appelle aiptek, c'est aiptektablet celui-ci ?

(et oui j'utilise un noyau normal)

Merci encore
HoaXyde.
KiBi
Messages : 901
Inscription : 27 déc. 2004, 00:57
Localisation : Brest, Dijon
Contact :

Message par KiBi »

Je n'ai pas trop le temps de regarder la configuration tout de suite ; j'avais suivi la doc sur le site officiel. Il y a des exemples de configuration dans le « Topic officiel » que j'évoquais plus haut.
Hoaxyde
Messages : 26
Inscription : 29 oct. 2005, 14:43

Message par Hoaxyde »

En adaptant la section, j'obtiens effectivement quelque chose dans les périphériques étendus !
Bon, reste plus qu'à trouver comment se servir de cette fichue pression, et ça roule.

Merci !
Hoaxyde
Messages : 26
Inscription : 29 oct. 2005, 14:43

Message par Hoaxyde »

Mine de rien, j'ai toujours pas la pression...
J'ai effectivement les options dans périphériques étendus, le "stylus" est bien activé, mais aucun changement par rapport à avant (sauf quelques problème avec X, mais bon) ! Le trait est uniforme. Faut-il changer un autre paramètre, dans les options de l'outil par exemple ? Utiliser une autre brosse ?
Et ce n'est pas un problème de la tablette : je vois avec wacdump le niveau de pression évoluer correctement.
C'est bien le Gimp qui est en cause, et je suis à court d'idées :(

Merci de votre aide :)
HoaXyde.
olivs
Administrateur
Administrateur
Messages : 2090
Inscription : 28 avr. 2004, 08:23
Localisation : Toulouse
Contact :

Message par olivs »

il me semble avoir lu/compris/deviné/inventé que pour bénéficier des niveaux de pression, tu es obligé de recompiler gtk + gimp

en revanche, ce qu'il serait intéressant de vérifier, c'est que la egstion des pressions fonctionne avec krita, qui est progressivement en train de se poser en concurent trèèèèès sérieux de gimp. il lui manque encore plein de fonctionnalités, mais il en a quelques unes en retour que gimp n'a pas... à surveiller
Hoaxyde
Messages : 26
Inscription : 29 oct. 2005, 14:43

Message par Hoaxyde »

J'obtiens la même chose, aucune différence entre les outils de la tablette activés ou desactivés...
Raymond
Admin de Gimp-fr
Messages : 710
Inscription : 25 août 2004, 18:09
Localisation : Strasbourg
Contact :

Message par Raymond »

Faut-il changer un autre paramètre, dans les options de l'outil par exemple ?


Chaque outil de dessin a dans ses options Sensibilité à la pression avec des cases à cocher.

il me semble avoir lu/compris/deviné/inventé que pour bénéficier des niveaux de pression, tu es obligé de recompiler gtk + gimp


Si sur ton système GTK a été compilé sans l'option --with-xinput alors tu ne vois pas de périphériques étendus (stylus, cursur, eraser) quand tu essayes de les configurer. C'est ce qui m'était arrivé sur une version de développement (2.1 de mémoire).

@+
Répondre